If you see people suggest installing "libmagick9-dev", that's an apt package that you'd install with:

$ sudo apt-get install libmagickwand-dev imagemagick
or on centos:

$ yum install ImageMagick-devel
On Mac OS, you can use Homebrew:

$ brew install imagemagick